nexmo-php v2.4.0

This release includes a minimum version bump to PHP 7.2, as 7.1 is nearing full EOL. This also better allows us to support Guzzle 7 out of the box.

Changed

  • #250 - Bumped minimum PHP version to 7.0
  • #250 - Now supports Guzzle 7 automatically, and swaps to Guzzle 7 as a dev dependency